说明:主要是练习类和对象的定义,用于笔试。
计算长方形的周长和面积(类和对象)
Problem Description
设计一个长方形类Rect,计算长方形的周长与面积。
成员变量:整型、私有的数据成员length(长)、width(宽);
构造方法如下:
(1)Rect(int length) —— 1个整数表示正方形的边长
(2)Rect(int length, int width)——2个整数分别表示长方形长和宽
成员方法:包含求面积和周长。(可适当添加其他方法)
要求:编写主函数,对Rect类进行测试,输出每个长方形的长、宽、周长和面积。
public class Main { public static void main(String[] args){
}
}
class Rect{
private int length,width;Rect(int length){ // 构造方法 this.length = length; } Rect(int length, int width){ this.length = length; this.width = width; } int getLength(){ //方法 return length; } int getWidth(){ return width; } int getArea(){ return length * width; } int getCirc(){ return (length + width) * 2; }
}
类就是这么定义的,就完成任务了吧。
但是根据题目的不同,再完善类的构造方法与方法。
Input
输入多组数据;
一行中若有1个整数,表示正方形的边长;
一行中若有2个整数(中间用空格间隔),表示长方形的长度、宽度。
若输入数据中有负数,则不表示任何图形,长、宽均为0。
Output
每行测试数据对应一行输出,格式为:(数据之间有1个空格)
长度 宽度 周长 面积
Sample Input
1
2 3
4 5
2
-2
-2 -3
Sample Output
1 1 4 1
2 3 10 6
4 5 18 20
2 2 8 4
0 0 0 0
0 0 0 0
import java.util.*;
public class Main {
public static void main(String[] args){
Scanner sc = new Scanner(System.in);
while(sc.hasNext()){
Rect re; // 声明对象
String str = sc.nextLine(); //读入
String []s = str.split(" "); //分割
int len = s.length; // 判断有几个数
if(len == 1){
int x = Integer.parseInt(s[0]); // 用这个方法来弄一下QAQ
re = new Rect(x);
}
else {
int x = Integer.parseInt(s[0]);
int y = Integer.parseInt(s[1]);
re = new Rect(x,y);
}
System.out.println(re.toStr());
}
}
}class Rect{
private int length,width;public Rect(int length){ // 构造方法 this (length, length); } public Rect(int length, int width){ if(length < 0) this.length = 0; if(width < 0) this.width = 0; this.length = length; this.width = width; } public int getLength(){ //方法 return length; } public int getWidth(){ return width; } public int getArea(){ return length * width; } public int getCirc(){ return (length + width) * 2; } // 自己定义一个输出,不定义也没事,再输出的时候自己处理一下 public String toStr(){ String res = length + " " + width + " " + getCirc() + " " + getArea() ; return res; }
}